Ntronium Forums
March 30, 2017, 11:35:11 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: SMF - Just Installed!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Won't install Armada .Net framework lower then 3.5  (Read 4284 times)
mbar
Beta Testers
Full Member
*
Posts: 134



« on: July 17, 2014, 07:11:22 PM »

I cannot install either my Armada 2526 or Gold game because it throws an error "Armada 2526 Gold cannot be installed on systems with .Net Framework version lower than 3.5"

I have the latest .net framework installed. I've run the NetFxRepairTool to no avail.

Windows 7 with .Net Framework version 4.5.1

Am I missing something simple?
Logged
finebone
Beta Testers
Hero Member
*
Posts: 1351



Email
« Reply #1 on: July 18, 2014, 04:37:44 AM »

Do you have .Net Framework 3.5 installed?  The error message could be misleading when it says lower than 3.5, it possibly should have just said you need 3.5.
Logged

If Armada 2526 is a hot fudge sunday, then Supernova is a bannanna split you can share with friends!
mbar
Beta Testers
Full Member
*
Posts: 134



« Reply #2 on: July 19, 2014, 08:01:14 PM »

I think I would have to somehow remove 4.5.1 and then I could install 3.5 because .net 3.5 will not install currently.
Logged
finebone
Beta Testers
Hero Member
*
Posts: 1351



Email
« Reply #3 on: July 21, 2014, 06:27:29 AM »

the .NET versions should be able to sit there side-by-side.  They're not upgrades of .NET in the same sense that most other programs upgrade.  It'd be like having Direct X 9 installed and also Direct X 10.  Some programs use each.
Logged

If Armada 2526 is a hot fudge sunday, then Supernova is a bannanna split you can share with friends!
mbar
Beta Testers
Full Member
*
Posts: 134



« Reply #4 on: July 22, 2014, 09:02:26 AM »

The 3.5 installer from Microsoft never worked. I downloaded one from Filehippo that ran but then told me I needed to "install with Turn Windows features on or off." Did that but still no joy. This is really odd as I've had Armada on this very PC before. (did the Supernova beta with it as a matter of fact.) I have Gold installed on my work PC < shhh! Smiley > and it has .net 1.1 and 4.5.1 and it installed there just fine.

Thanks for the ideas but I'm beginning to think the only way to really fix this is do a factory restore. I'm playing just fine on my primary laptop, I just wanted to get Armada installed on my traveling laptop.
Logged
mbar
Beta Testers
Full Member
*
Posts: 134



« Reply #5 on: July 22, 2014, 02:57:02 PM »

I FIXED IT!!!!!!
Just for one last try I went into the "Turn Windows features on or off" area and disabled .net framework 3.5.1. Then I enabled it again. Fixed it right up. I'm so glad I didn't need to do a factory reset.

 Grin
Logged
finebone
Beta Testers
Hero Member
*
Posts: 1351



Email
« Reply #6 on: July 25, 2014, 04:29:45 AM »

wow, usually advice like "turn something off then back on again" doesn't work.  glad it did for you!
Logged

If Armada 2526 is a hot fudge sunday, then Supernova is a bannanna split you can share with friends!
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!